WorkflowGen 8.0.1 Beta

Important

  • This is a BETA version.

Portal

  • Feature (#2392, #3368): Advanced View: Support grid export to Excel (XLSX) file format.

  • Bug (#2244): Fixed a process name/description sorting issue in some process filter lists.

  • Bug (#3446): Fixed a The multi-part identifier ... could not be bound. SqlException error that was raised in the advanced search when searching for actions on some specific SQL Server versions/configurations.

  • Bug (#3449): Fixed an issue where a supervisor, manager, or administrator would still have access to the advanced search in supervisor mode in delegation.

Administration

  • Bug (#3418): Fixed an encoding issue with Unicode characters in the transition/notification condition editor.

  • Bug (#3428, #3451): Fixed some warning/error message UI alignment issues in some pop-up dialogs.

Configuration Panel

  • Bug (#3466): DOCUSIGN application: Fixed an issue where a properly defined RSA key in the \wfgen\web.config file was not detected.

Workflow Engine

  • Breaking change (#3315): Removed the legacy engine trace mode e.g. EngineTraceMode.

Workflow Applications

  • Bug (#3470): EXECSQL application: Fixed an issue where a CMDx command would not be executed when the parameter CMDx_TYPE was not defined.

WorkflowGen.My v8.0.0

  • Change (#3481): GlobalLists: Added deprecated fetchList methods.

Remote Approval (workflow engine service)

GraphQL v5.0.2 & Webhooks v6.0.3

  • Bug (#3435): Fixed an issue where the UpdateApplication mutation was not allowing the update of an existing application.

  • Bug (#3440): Fixed an issue where the GetRequests and GetActions operations were not returning any requests or actions for a standard user in delegation mode.

  • Updated Node.js vulnerable dependencies.

Auth v3.0.2

  • Bug (#3441): OIDC authentication: Fixed an issue where the username was retrieved from the access token using the wrong claim.

  • Bug (#3452): OIDC authentication: Fixed an access token schema issue for AD FS.

  • Updated Node.js vulnerable dependencies.

SCIM v3.0.2

  • Updated Node.js vulnerable dependencies.

Database

  • Bug (#3434): Fixed some SQL query syntax issues in the version 8 database upgrade script e.g. Update_WFG-V8-0-0.sql.

Notes

  • All of the Node.js modules (GraphQL v5.0.2, Webhooks v6.0.3, Auth v3.0.2, and SCIM v3.0.2) now require Node.js version 14.16.1 LTS.
  • Please refer to the WorkflowGen 8.0.0 Beta release note for all the new features and changes in the new version 8.

Reminders

  • Oracle database is no longer supported as of WorkflowGen version 7.16.0. We recommend migrating to MS SQL Server 2017 or later.

  • For clients currently hosting WorkflowGen on a database server older than MS SQL Server 2012, we highly recommend upgrading to MS SQL Server 2017 or later for the best performance.

Installation Packs

WorkflowGen 8.0.1 (Upgrade)
WorkflowGen 8.0.1 (Clean Install - PowerShell)
WorkflowGen 8.0.1 (Clean Install - manual)

Documentation

WorkflowGen 8.0.1 Beta Upgrade Guide: English - Français
WorkflowGen 8.0 Beta PowerShell Installation: English - Français
WorkflowGen 8.0 Beta Manual Installation: English - Français
WorkflowGen 8.0 Beta Technical Guide: English - Français
WorkflowGen 8.0 Beta Administration Guide: English - Français
WorkflowGen 8.0 Beta User Portal Guide: English - Français
WorkflowGen 8.0 Beta Integration Guide: English
WorkflowGen 8.0 Beta for Azure: English - Français
WorkflowGen 8.0 Beta for Docker: English - Français
WorkflowGen documentation: English - Français