Remove the wfgen sub folder/application


#1

Hi,

I have been using WorkflowGen for over 10 years now and everytime I do a new install I hate seeing that sub application /wfgen/ in IIS. I hate having the users remember that Url. Is there a way to remove that application and simply install WorkflowGen on the root Website?

So instead of always having to go to http://localhost/wfgen, you can simply go to http://localhost.

The URL rewrite option is not a solution, I don’t want to redirect the user, I want to get rid of the /wfgen/ sub folder completely.

Thanks,


#2

Hi,

In IIS, you can simply change the physical path of the root website to “…\wwwroot\wfgen” instead of “…\wwwroot”. Localhost will then point to the \wfgen folder.
(Right click on website -> Manage Website -> Advanced Settings…)

Make sure to also modify the Application URL configuration so that it matches with your setup changes.

Best Regards,
Eddy.


#3

I will try that approach again. In the past, this caused problems since some parts of the system always point to /wfgen/.

I will try and let you know if it works.

Thanks,


#4

The solution you recommend does not work because of the WorkflowGen Engine Service. Look at this discussion for explanation.


#5

Hi,

This is a very old article (9 years old) and I’m discussing with the team to remove it.
I tried my solution and it worked fine without the “/wfgen” path. The services were running fine as well.
Have you tried it on your side?

Best Regards,
Eddy.


#6

I will try it again and let you know.


#7

It doesn’t work for me. New installation from PowerShell. I get the following error when trying to run the service. If I change it back with the wfgen subfolder, it works.

Service cannot be started. System.NullReferenceException: Object reference not set to an instance of an object.
   at Advantys.Workflow.Win.Services.EngineService.CheckTimeLimitService.OnStart(String[] args)
   at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)

<exception callerId="WorkflowGenEngineService ServiceLoad"><source>mscorlib</source><message>Length cannot be less than zero.
Parameter name: length</message><type>System.ArgumentOutOfRangeException</type><stackTrace><![CDATA[   at System.String.Substring(Int32 startIndex, Int32 length)
   at Advantys.Workflow.Win.Services.EngineService.ServiceController.LoadConfiguration()
   at Advantys.Workflow.Win.Services.EngineService.CheckTimeLimitService..ctor()]]></stackTrace><innerException></innerException></exception>

#8

Wait a minute! I found the problem.

When there is no end slash “/” at the end of the Url in the Web.config, it doesn’t work. Making sure that ending slash is there works!

This does not work:
<add key="ApplicationUrl" value="http://localhost" />

This works!
<add key="ApplicationUrl" value="http://localhost/" />

So make sure the end slash at http://localhost/ is there!


#9

Here is another issue I found with the graphql.

You need to modify the server.js file to change the rootUrl

const rootUrl = ‘/graphql’;

Instead of…

const rootUrl = ‘/*/graphql’;


#10

Hi,
Thank you for mentioning this. We will correct this in the upcoming version.

Best Regards,
Eddy.