Hiding data elements in follow up form and form archive

Hello,

Could you please help me in following : how to hide a data element in follow-up form and form archive and do reports and search based on it?

Hi @MilicaSA,

First, to show a data in the Search tool, you must enable “Display in column in the lists”. Note that the “Show the data in the follow-up forms” option must be enabled first to enable the second option. (1)

By default, data is shown to all participants. But you can change that and indicate specific participants to see that data by clicking on “All participants” next to “Security” (2) and then you can choose specific participants to view this data. Only the selected participants will be able to view the data in the follow-up form and search tool.

Hope this helps.

Hi Eddy,

Thank you very much for feedback!
I’ve implemented this solution and select participant that should be able to see particular data element, however - it was still visible in follow-up form.
And then I’ve tried option “no access”, and after that data element was not visible in follow-up form (except for admin) though it was visible for search option. Is this result OK - does it suppose to work this way with this option?

Milica Savic

Hi @MilicaSA ,

These settings only apply to participants with a requester or actor role.
If you put “no access” that means all the participants with a requester or actor role cannot see the data.

If you are a supervisor, manager or administrator, you will always have access to all the data in the process.

So the behavior depends on your role and the data settings.

Hi again,

I followed the received recommendations (I was not in the role of administrator, supervisor or manager in the process and in the “security” section I set that only a certain participant has the access to data element) and the result is that as a regular user I see data from a specific data element. is there anything else that needs to be adjusted?
Thank you very much!
Regards,
Milica Savic