Remove domain name when login with IIS authentication


#1

I have selected IIS for authentication and linked to AD to retrieve my user listing. My users will always need to type ‘domain/username’ during login and being a new implementation, many of them are not aware that they need to type in the domain in front. Is it possible to do any settings such that the users do not need to enter the domain during login or to append the domain name to their login username before authentication?


#2

Hi @stareast,

There are two types of authentications that WorkflowGen uses with IIS.

Windows Integrated authentication: The users don’t need to put any credentials to authenticate; the system will automatically log them in with the user they are logged in on their computer.

Basic authentication: The users need to put valid credentials. If the users are not local Windows users, there is no way the system can identify them, so a domain name is required for a successful log in. You can always create a custom module for your authentication to concatenate the domain name with the username but that is not supported by default with WorkflowGen.

Regards,
Eddy.


#3

Hi Eddy, thanks for the prompt reply. May i know how do i set it as Windows Integrated authentication?
Also, how do i create a custom module for my authentication to concat with the domain name?
Thanks!


#4

If i choose Windows Integrated authentication, may i know what happens if my users are accessing from their home computer and login to their own home computer windows account, using vpn to access workflowgen hosted on our company intranet? Will they be able to login to workflowgen hosted on our intranet since they are not login to the company user account on windows? Thanks in advance.


#5

Hi, any response from anyone?


#6

Hi @stareast,

First, In the WorkflowGen site, make sure that you are using IIS authentication mode in the the Admin section Configuration Panel -> General -> Authentication -> Mode

Second, in IIS, click on the WorkflowGen site then “Authentication” feature under the IIS section:
Disable all authentications and only enable Windows Authentication.

Here is an article regarding this:

This setup will not work with Windows Integrated since the system won’t be able to identify the user.
A good solution to make it work with Windows authentication is to give the users remote access to their work computer. They would be able to login in their work computer remotely and authenticate successfully with Windows authentication.

Happy Holidays!

Regards,
Eddy.


#7

Thanks Eddy! Happy Holidays to u too.