Install Error WorkflowGen 7.16.3 ( Locking is either by default (overrideModeDefault="Deny"))

I’m trying to install WorkflowGen 7.16.3 on Windows Server 2016 using the powershell install. I get the following error at step “14. Granting permissions for WorkflowGen files and folders…”

An error occurred, details are located in the log file.
This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault=“Deny”), or set
explicitly by a location tag with overrideMode=“Deny” or the legacy allowOverride=“false”.

If I run the install again I get this error in the Log files:
15. Converting WorkflowGen physical folders to web applications…
ConvertTo-WebApplication : Cannot convert item ‘IIS:\Sites\WFGen\wfgen\WfApps\WebForms’ to application.
At F:\powershell-setup-7.16.3\scripts\build.ps1:213 char:3

  • ConvertTo-WebApplication (“IIS:\Sites”+settings.IISSiteName+"\"+
  • + CategoryInfo          : InvalidOperation: (:) [ConvertTo-WebApplication], ArgumentException
    + FullyQualifiedErrorId : invalidOperation,Microsoft.IIs.PowerShell.Provider.ConvertToApplicationCommand

Any help greatly appreciated.



Hi @BrianDIrl ,

If you reached point 15 that means you have fixed the error that occured in 14.

To fix 15, I believe deleting the WorkflowGen Site created in IIS and restarting the installation should make it work.


1 Like

Hi Eddy,

Thanks for the reply, I’ve tried deleting the site and its associated files, I then error out on reinstall at step 14. If I just delete the site but not the associated files I still error out converting to Webapps. I’m wonder if its to do with permissions and the app pool?



Hi Eddy,

Thanks so much for your help. I reset the VM and went through the process again, this Time I followed your recommendation and it work first time!

Thanks for your help.

Regards Brian

1 Like