Impersonateusername parameter is being ignored

The ImpersonateUsername parameter is being ignored when using the URL below.


Instead it’s using the UserName that i’m authenticating with. Any ideas why?


I just tested on the latest version. The impersonateusername parameter does work fine.

Make sure the username of the person using the impersonation is defined in the WorkflowGen main web.config’s parameter ProcessesRuntimeWebServiceAllowedUsers as indicated in the article Web Services API: User Impersonation with ImpersonateUsername parameter.

e.g. <add key="ProcessesRuntimeWebServiceAllowedUsers" value="wfgen_admin" />

In this example, wfgfen_admin can impersonate jsmith when specifying impersonateusername=jsmith in the URL.