How do i setup KEYWORDS_BRACKETS to accept other values other than default brackets?


#1

Hi, my company outlook email embeds [classification] on every reply email hence when i set quick mode remote approval, system is unable to recognize the answer to the approval.

For eg i reply the email to below:

Reject
Not eligible.

My outlook reply will embed it with a mail classification such that it become this:

[Classification]
Reject
Not eligible

Any idea how can i make the system strip away the [Classification] word or how do i customize my answer format so that system can read my approval even with the [Classification] on the first line?

Thanks in advance.


#2

Hi @stareast ,

How do i setup KEYWORDS_BRACKETS to accept other values other than default brackets?

In the action’s parameter tab, add a new parameter with the name KEYWORD_BRACKETS and set the value to ## for example.

Here is a complete documentation on how to use the parameter:
https://docs.advantys.com/workflowgen-administration-module-reference-guide/remote-approval#default-parameters-for-remote-approval-actions

Any idea how can i make the system strip away the [Classification] word?

This is not possible using quick mode approval, you’ll have to use regular approval mode for your case.

Regards,
Eddy.


#3

Hi Eddy, thanks for the fast reply.
I tried adding KEYWORDS_BRACKETS as what you shown, as well as set Q1_KEYWORDS_1, Q1_KEYWORDS_2, Q1_RESULT_1, Q1_RESULT_2, Q1_RETURN_FIELDNAME in the parameters as according to the documentation. I have also set Quick approval enabled at the Data Out Quick approval tab. However i tried to email my response in the format below:

Q1: #Yes#
Comment: #OK#

It still returns me an email saying incorrect format. Am i missing anything else here?


#4

Hi @stareast,

In the Administration module -> Configuration Panel -> Remote Approval, did you disable Quick Mode?
If that is the case, please open a ticket in our Helpdesk site so we can investigate the issue.

Regards,
Eddy.


#5

Hi Eddy, it doesn’t work regardless i turn Quick Mode on or off in config panel…


#6

Hi @stareast,

Please open a ticket in Zendesk so we can investigate the issue.

Regards,
Eddy.