WorkflowGen 7.15.5

Portal

  • Bug (#2753): Fixed some XSS security vulnerabilities.

Workflow Applications

  • Bug (#2751): RESTAPICLIENT: Fixed an issue where a remote server would return an HTTP error 411 The request must be chunked or have a content length when using the POST method with an empty payload.

  • Bug (#2752): SENDMESSAGE: Fixed a connection issue with the Twilio messaging API, which now requires the TLS1.2 protocol.

GraphQL

  • Updated Node.js vulnerable dependencies (extend and lodash).

Auth

  • Updated Node.js vulnerable dependencies (extend and lodash).

Notes

  • All of the Node.js modules (GraphQL v2.0.4, Webhooks v4.0.1, Auth v1.0.3, and SCIM v1.0.2) now require Node.js version 10.15.3 LTS.

  • Running the npm install --production command is required on each of the modules (\wfgen\graphql, \wfgen\hooks, \wfgen\auth, and \wfgen\scim) after the upgrade.

Reminders

  • Microsoft Windows Server 2008 is no longer supported as of WorkflowGen version 7.11.0. We recommend migrating to Windows Server 2012 or later.

  • Microsoft SQL Server 2008 is no longer supported as of WorkflowGen version 7.10.0. While SQL Server 2008 is still compatible with WorkflowGen, support for any performance issues or bugs resulting from using SQL Server 2008 will no longer be provided.

    For clients currently hosting WorkflowGen on a database server older than MS SQL Server 2012, we highly recommend upgrading to MS SQL Server 2017 or 2019 for the best performance.

Installation Packs

WorkflowGen 7.15.5 (Upgrade)
WorkflowGen 7.15.5 (Clean Install - PowerShell)
WorkflowGen 7.15.5 (Clean Install - manual)
WorkflowGen.My

Documentation

WorkflowGen 7.15.5 Upgrade Guide
WorkflowGen 7.15.5 Technical Guide
WorkflowGen 7.15.5 Administration Guide
WorkflowGen 7.15.5 User Portal Guide
WorkflowGen 7.15.5 Integration Guide