Debugging SMTP Issues


#1

I’ve just installed WorkflowGen and I’ve assigned the SMTP server value to our relay smarthost SMTP server. I’m not getting any notifications via email and I’m wondering how to start the process of debugging.

Is there a way to confirm that my process workflow is firing the notification to go out?

Is there an error log or running process that I can check to see if messages were at least attempted to send to the SMTP server?

I can’t really tell if I have the SMTP setup correctly or if the workflow just isn’t firing anything off or if the relay server is not accepting the relay (which I doubt because it is used by other servers and we verified the whitelist settings for this server).

Any help would be great.

Thanks in advance.


#2

I will need more information in order for me to provide you with a better detailed troubleshoot:

  • Which SMTP server are you using?
  • Which Operating System are you using in your file server?

First, you can test the basic settings of your SMTP connection by going in the Admin module -> Configuration Panel -> General -> SMTP. To test the SMTP configuration, click the Test button and provide sender and recipient email addresses. An email will be sent to the address you specified.

Test Failed.

If the test failed, there is probably an error that occurred on the SMTP server side. You can get more details of this error in the SMTP logs.

Test Succeded

If the test succeeded, this means you have issues in the WorkflowGen Server side.
If you are using WorkflowGen version 6.0 and higher, go to Admin module -> Configuration Panel -> Portal-> User notification and make sure to select the option “2-All notifications” for the configuration Log level to get as many details as possible.You can check the logs located in \wfgen\App_Data\LogFiles\Notifications.

You can also check the Event Viewer in the server that handles your Services. The WorkflowGen Engine Service also handles some notifications. You might find an error related to your issue.

Hope this helps,
Eddy.


#3

Hi Eddy,

Thanks for the quick response:

We are running Windows 2012 R2 server. After I posted this I went in and found the Admin module and the SMTP test settings. I ran the test and it failed - so I definitely I have an issue which I will troubleshoot more.

Thanks for the tip on the log information - I will employ it.

Lastly, I had a question about the recommended way to setup the actual SMTP in the documentation:

Are the docs saying that you should configure the SMTP server on the actual server itself and then set that up to relay to the remote SMTP server OR can I just specify the remote SMTP server to allow relays?

Thanks again!
-m


#4

FYI - the issues were totally related to our infrastructure. As soon as the SMTP relay issue was fixed, everything worked perfectly as documented.

Anyone who is having issues with the WorfkflowGen needs to verify completely that they can relay SMTP first.