# WorkflowGen 5.4

**URL:** <https://discuss.workflowgen.com/t/workflowgen-5-4/548>\
**Category:** Release Notes & Downloads\
**Created:** [November 30, 2011, 5:06am UTC](https://discuss.workflowgen.com/t/workflowgen-5-4/548 "2011-11-30T05:06:10Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![wfg-admin](https://yyz2.discourse-cdn.com/flex030/user_avatar/discuss.workflowgen.com/wfg-admin/32/714_2.png) [@wfg-admin](https://discuss.workflowgen.com/u/wfg-admin)\
**Post date:** [November 30, 2011, 5:06am UTC](https://discuss.workflowgen.com/t/workflowgen-5-4/548/1 "2011-11-30T05:06:10Z")

</div>

#### Version 5.x support ends June 30, 2017

Support and maintenance for version 5.x will end on **June 30, 2017**. If you are still running version 5, we recommend you plan a migration, and we will be happy to help should you need any assistance.

**Administration**

- #2973: NEW FEATURE - Form Designer.

- #3050: UPDATE - It is now possible to set the minutes and seconds for the working hours.

- #3012: UPDATE - The administration process request deletion now supports date filtering with one or two dates.

- #3047: BUG - Directory Synchronization: A manager account was not found if the username is prefixed and is on a different directory.

**Portal**

- #2957: UPDATE - Search and statistics data report performance optimization.

- #3028: UPDATE - WorkflowGen now supports French (Switzerland) localization.

- #3048: UPDATE - Supports Hungarian date/time format validation.

- #3052: UPDATE - Date fields validation and autocomplete behaviour improvement.

- #3003, 3038, 3031, 3033, 3051: UPDATE - Security patches.

- #3042: BUG - The calculation of the deadline could be wrong when using the working days/hours to calculate the duration.

- #3036: BUG - The icon and process name under the New Request section in the homepage were not aligned properly when the process name exceeds some length.

- #3040: BUG - It was not possible to disable the graphical follow-up for some supervisors.

- #3049: BUG - The webform was using the user’s preferred language for data formatting when an application language is defined.

- #3013: BUG - The action follow-up result list was displaying the requester name in the column ‘Participant’ after sorting by a process data column.

- #3032: BUG - A request not found error was raised when using the request quick search in mono-process mode.

- #3022: BUG - A request not found error was displayed when navigating from a parent to sub request and the portal is filtered by the parent process.

- #3030: BUG - An exception error was raised in the search form when switching from a specific process version to a different process.

- #3017: BUG - An exception error was raised when completing an action and there a many concurrent users connected on the WorkflowGen server.

- #3024: BUG - An exception error was raised when the Workflow engine service logs a XML error string that is over the maximum allowed log entry length.

- #3020: BUG - A XML exception error was raised when invoking the GetActivityInstanceList method with the process instance data enabled.
